Zenith host - Billing panel – Incident details
Zenith Hosting
Zenith Hosting
Uk01 experiencing major outage
Billing panel
Resolved
Major outage
Started about 2 months ago
Lasted 13 days
Affected
Client/Billing Panel
Major outage from 10:41 PM to 5:18 PM, Degraded performance from 5:18 PM to 5:28 PM
Updates
Resolved
October 30, 2025 at 5:28 PM
Resolved
October 30, 2025 at 5:28 PM
This incident has been resolved.
Monitoring
October 18, 2025 at 5:18 PM
Monitoring
October 18, 2025 at 5:18 PM
We implemented a fix and are currently monitoring the result.
Identified
October 18, 2025 at 2:22 AM
Identified
October 18, 2025 at 2:22 AM
We are continuing to work on a fix for this incident.
Investigating
October 17, 2025 at 10:41 PM
Investigating
October 17, 2025 at 10:41 PM
We are currently investigating this incident.